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Importing Data from Excel Into MINITAB Using ODBC

Introduction

The purpose of this document is to demonstrate how to use MINITAB’s File> Query Database
(ODBC) method to import data from a database (e.g. Excel) into MINITAB. There are many
different choices to be made in setting up ODBC and many different ways to do it. This
document presents two examples. The first sets up a simple one-time link that produces the
code necessary to implement ODBC from VBA in Word. The second example creates a new link
accessible from MINITAB any time a manual connection to the data file is required.

There are instructions for using ODBC posted at MINTAB's web site that start here:
http://support.minitab.com/en-us/minitab/17/topic-library/minitab-environment/input-
output/import-data-from-a-database-with-odbc/basics-of-odbc-in-minitab/
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Example 1 — One-Time ODBC Connection

In this example we will use an ODBC connection to import data from an Excel file into MINITAB.
The target Excel file should already exist and have data in it. The code produced by this method
can be saved in a MINITAB LOCAL macro and called as needed from MINITAB or using VBA from
Word.

From MINITAB start configuring ODBC by clicking File> Query Database (ODBC). You will see
this window.

Select Data Source

File Data Source l tachine Data Source

Look in: |Data Sources hd

DOSM Mame: || e

=electthe file data source that describes the driver that wou wish o connectto. You
can use any file data source that refers to an ODBC driver which is installed on wour
machine.

K Cancel Help
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The File Data Source and Machine Data Source tabs select options that control the location of
and user access to the data. See the following link for more information on this issue.
https://msdn.microsoft.com/en-us/library/ee265698%28v=bts.10%29.aspx

For the purpose of our example choose the Machine Data Source tab.

Select Data Source

File Data Source Machine Data Source

Data Source Name Twpe Description
dBASE Files Lser
Excel Files Lser
b3S Access Database Lser
Yisual FoxPro Database Lser
Yizual FoxPro Tahles Lser

A bdachine Data Source is specificto this machine, and cannat be shared. "User" data
sources are specificto a user on this machine, "System" data sources can be used by
all users on this machine, or by a system-wide service.

0].8 Cancel Help
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Choose Excel Files and click OK.

If you click New at this point you will be lead through a lengthy process of creating a new Data
Source Name (DSN) link to your Excel file. The new DSN will be added to the list in the GUI so
that you can access that Excel file by ODBC whenever you want. The steps to create the new
link are described in Example 2.

Select Data Source

File Data Source Machine Data Source

Data Source Mame Type Descrigtion
dBASE Files Lser
Excel Files Lser
b5 Access Database Lser
Yisual FoxPro Database Lser
Yisual FoxPro Tahles Lser

A bdachine Data Source is specificto this machine, and cannat be shared. "User" data
sources are specificto a user on this machine. "System" data sources can be used by
all users on this machine. or by a system-wide service.

K, Cancel Help
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The program opens a file browser window. Navigate to the folder where your data file is
located.

Select Workbook &‘

Database MName Directories: 0K
m ch. Ay documents
Cancel
= ch A
[= DOCUMEMNTS AMD f—
(= PALL MATHEWS Help
B WY DOCUMENTS
£ Access Connection [ Bead Only
3 Bluetooth Exchange
£ Downloads
£ My Data Sources
List Files af Type: Crives:
Excel Files {*xls*) - | = ¢ Preload - Metwork. .

Click on your data file name in the list box on the left and then click OK.

Select Workbook &‘

Database MName Directories: 0K
|NITAEE CDBC functionality xls chstatisticsyminitabhodbc
Cancel

Data far test of MIMNITAB (= oy

(= Statfistics

= MIMITAB Help

&= ODEC
[ BeadOnly

List Files af Type: Crives:
Excel Files {*xls*) - | = ¢ Preload - Metwork. .
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This GUI shows the worksheets of the Excel file and the columns in those worksheets that are available
for import.

Query Database (ODBC) X ‘

Available tables:

Available fields: Selected fields:

¥

Ll

[v List available tables and fields in alphabetical order

Help 0] 4 Cancel
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Choose the worksheet from the Excel file in the Available tables list box and then select the
columns that you want to import from Excel into MINITAB. Then click OK.

Query Database (ODBC) &‘

Available tables:

ISheet1s |

Available fields: Selected fields:

¥

<<

flLL

[v List available tables and figlds in alphabetical order

Lse rows., ..

Cancel

il

Help
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The ODBC command is complete and runs. The Session window shows the ODBC command
and the imported data appear in columns C1 and C2 in the MINITAB worksheet.

ol Minitab - Untitled

i Fle Edit Data Calc Stat Graph Editor Tools Window Help Assistant

SH S S DE 0ol T 48 080 R Tt YOR R A ot] | =all,

EJ Session

Welcome to Minitak, press Fl for help.
MTE > ODEC;
SUBC> Connect "DSN=Excel Files;DBQ=C:%Statistics\MINITAB.ODECYData for test of MI" &

COHT > "WITAE ODBC functionality.xls;DefaultDir=C:%\S8tatistics \MINITAR\WCODBC;DriverI™ &
CONT > "d=1046;MaxBufferfize=2048; PageTimecut=5;";

SUBC> 3QLString "SELECT “ID', ¥~ FROM “C:%Statistics\MINITAB\.ODEC\Data for test o" &
CONT > "f MINITAE ODEC functionality.xls'. ZShestlS™".

Successtully retrieved ODBEC data =set
Data Source Name: Excel Files
Database Name: C:\Statistics‘\MINITAB\ODEC\Data for test of MINITAE ODBC functionality.=xls
DEME Nams: EXCEL
DEMZ Version: 12.00.0000
MTE > |

< 1} |

E= Worksheet 1 ***

+ c1 cz c3 c4 C5 (o] c7 cs co c10 c11 c12
ID y
1 10 -1.15168
2 1 -0.76759
3 1 0.24369
4 1 -0.03624
5 2 -0.19261
53 2 -018307
7 2 -0.81095
8 2 -0.80290
9 3117278
10 3 -1.54969
11 3 -1.01620
EN p ]

Current Worksheet: Worksheet 1
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If you intend to access data from this Excel file automatically using a VBA call from Word then create an EXEC macro containing the ODBC code.
Copy the ODBC code from the Session or History window, then paste the code into a text file (use NotePad). Save the file with the .mtb file
extension in your MINITAB Macros folder. Run the macro as needed from the File> Other Files> Run an EXEC menu.

Here is the ODBC code as copied from the History window. The ampersand (&) symbols at the ends of some lines are MINITAB’s line
continuation character for lines that are too long to break.

ODBC;
Connect "DSN=Excel Files;DBQ=C:\Statistics\MINITAB\ODBC\Data for test of MI" &
"NITAB ODBC functionality.xls;DefaultDir=C:\Statistics\MINITAB\ODBC;DriverI" &
"d=1046;MaxBufferSize=2048;PageTimeout=5;";
SQLString "SELECT "ID , y FROM "C:\Statistics\MINITAB\ODBC\Data for test o" &
"f MINITAB ODBC functionality.xls . Sheetl$ ".

Here is the same code with the line breaks cleaned up. The lines from Connect to PageTimeOQOut are all one MINITAB subcommand line strung
together by the &s. Note the semicolon at the end of the PageTimeOut command that ends the Connect subcommand. The SQLString command
is broken over two lines and is the one that selects which columns to import from Excel into MINITAB. This code can be copied to the MINITAB
command line and run or it can be saved as an EXEC macro with the .mtb file extension and then called as needed. The macro method is
preferred for implementing ODBC calls from within VBA code in Word.

ODBC;
Connect &
"DSN=Excel Files;" &
"DBQ=C:\Statistics\MINITAB\ODBC\Data for test of MINITAB ODBC functionality.xls;" &
"DefaultDir=C:\Statistics\MINITAB\ODBC;" &
"DriverId=1046;" &
"MaxBufferSize=2048;" &
"PageTimeout=5;";
SQLString "SELECT "ID , y FROM "C:\Statistics\MINITAB\ODBC\Data for test of " &
"MINITAB ODBC functionality.xls . Sheetl$ ™ ".
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Example 2 — New Permanent ODBC Connection

This example creates a new permanent ODBC Data Source Name (DSN) that, after it’s initially
set up, simplifies making the ODBC connection to Excel from MINITAB.

From MINITAB click File> Query Database (ODBC), then select the Machine Source Data tab,
under the Data Source Name window select Excel Files, and then click New. In the next menu,
shown below, choose User Data Source or System Data Source depending on who should have
access to the data. Then click Next.

Create New Data Source I; ‘

select a type of data source:

(o Lser Data Source (Applies to this maching ok

(" Swystem Data Source (Applies to this machine only)

selecting User Data Source creates a data source which
is gpecificto this machine, and wisible only to you.

Mext > Cancel
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In the next menu choose a driver appropriate to the file type of the data source. There are
several drivers available for Excel. The one chosen below is the most modern and the most
likely to work for modern versions of Excel. Click Next and MINITAB will confirm your choice of
driver as shown in the screen shot on the next page.

Create New Data Source X ‘

=elect a driver for which you wantto set up a data source.
Marme YErsl A
Microsoft dBase Driver (*.dif) 4.00.F
bicrosoft dBase WFF Driver (*.dbf) 6.00:
bicrosoft dBase-Treiber (* dbf) 4.00¢
Microsoft Excel Driver (*:xds) 4.00.1
Microsoft Excel Driver (*x]: iy 12.00
bicrosoft Excel-Treiber (*xls) 4.00¢
bicrosoft FoxPro WFF Driver (*.dbf) 6.00:
Microsoft ODBC for Oracle 2575
Microsoft Paradox Driver (*.db ) 4008 «
< ¥
< Back Ml > Cancel
Page 11/18

Mathews Malnar and Bailey, Inc., 466 West Jackson Street, Painesville OH 44077
Phone: 440-350-0911 E-mail: paul@mmbstatistical.com



Mathews Malnar and Bailey, Inc. V20160129

If you chose the correct driver then click Finish.

Create New Data Source X ‘

“When yau click Finish, you will create the data source which you

hawe just configured. The driver may prompt ywou for more
infarmation.

lser Data Source
Diriver; Microgoft Excel Driver (*xls, *xlsx, *xlsm, *xlsh)

< Back Finish Cancel
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Enter a Data Source Name and an appropriate description of the data file or activity type. The
name specified in the Data Source Name field (no more than 32 characters) will be used as the
name of an ODBC data source name file with the .dsn file extension. Choose the Excel version,
then click Select Workbook.

ODBC Microsoft Excel Setup

Data Source Mame: ||
Description: | Cancel

Database

_ Help
Yersion: |Exeel 12.0 M
Workhbook:
SelectWorkbook... |
B Cptions>>

Navigate to the folder containing the data file (Directories), select the data file (Database
Name), and then click OK.

Select Workbook &‘

Database MName Directories: 0K
|NITAEE CDBC functionality xls chstatisticsyminitabhodbc
Cancel

Data far test of MIMNITAB (= oy

(= Statfistics

= MIMITAB Help

&= ODEC
[v BEead Only

List Files af Type: Crives:
Excel Files {*xls*) - | = ¢ Preload - Metwork. .
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With a data source name specified and the workbook selected click OK.

ODBC Microsoft Excel Setup

Data Source Name:  |Dema ODEC Excel/MINITAB oK
Description: |DEFﬂD Cancel
Database
_ Help
Yersion: |Exeel 12.0 M

Workhbook: Ch.s

SelectWorkbook... |

Cptions>>
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A new ODBC connection has been created and added to the list of available connections. Any
time in the future that you want to make this ODBC connection you can choose this item from
the list.

FYI: To remove a data source from this list, in Windows go to Start> Control Panel>
Administrative Tools> Data Sources (ODBC). Then select and delete the item from the list.

With the new connection selected click OK.

Select Data Source

File Data Source  Machine Data Source

Data Source Name Twpe Description
dBASE Files Lser

Demo ODBC Excel/MINITAB Lser Demo
Excel Files Lser

b5 Access Database Lser

Yisual FoxPro Database Lser

Yisual FoxPro Tahles Lser

A Machine Data Source is specific to this machine, and cannot be shared. "User" data
sources are specificto a user on this machine. "System" data sources can be used by
all users on this machine, or by a system-wide service.

0].8 Cancel Help
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Confirm that the correct workbook is selected and click OK.

Select Workbook &‘

Database Mame Directories: 0K
chstatisticsyminitabhodbc
Cancel

Data fortest of MINITAE = o,

(= Statfistics

= MIMITAR Help

&= oDBC

[ Bead Only

List Files of Type: Drives:
Excel Files (*xs*) v | = c: Preload - Metwork. ..
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Choose the worksheet in the Excel file and the columns to be imported into MINITAB. Then click

OK.
Query Database (ODBC) &‘

Available tables:

ISheet1s |

Available fields: Selected fields:

¥

<<

flLL

[v List available tables and figlds in alphabetical order

Lse rows., ..

Cancel

il

Help
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The ODBC code to make the Excel/MINITAB connection appears in the Session window and the
data from Excel are imported into the MINITAB Worksheet.

o Minitab - Untitled

i Fle Edit Data Calc Stat Graph Edtor Tools Window Help  Assistant

EHE DB 0 Dt 8N SO

;q‘ Session

TN OTS RERaR ot i i=talh, A

Welcome to Minitab, press F1 for help.
MTE > OQODBC;

SUBC>
CONT >
CONT >
SUBCH
CONTZ>

Connect "DSN=Demo ODBC Excel /MINITAEB;:;DBQ=C:%S8tatistice\MINITAB\ODEC\Data fo" &
"r test of MINITAE ODBC functicnality.xls:DefaultDir=C:'\gtatistics\MINITABL" &
"ODBC;DriverId=1046;FIL=excel 1Z2.0;MaxBufferfize=2048;PageTimecut=5;";
20LString "SELECT ‘IDY, "y"* FROM “C:\Statistics\MINITAB“ODEC\Data for test o" &
"f MINITAE ODEBC functionality.xls. Sheetl3™".

Successfully retrieved ODBC data set
Data Source Name: Demo ODEC Excel /MINITAB
Database MName: C:'%Etatistics\MINITAB.ODEC.Data for test of MINITAE ODBEC functicnality.uls

D

BME Name: EXCEL

DEMS Version: 12.00.0000
MTE > |

s

E= Worksheet 1 ***

+

C1

c2 C3 C4 cs Cé Cc7 c8 co C10 C11 c12

ID

Y

Toe@Ne o swn =

A

-1.15168
-0.76758

0.24368
-0.03624
-0.19261
-0.16307
-0.81085
-0.90280

1.17278
-1.54968
-1.01620

(SNSRI SV S T N R T N T e N

=N r ]
Current Warksheet: Worksheet 1
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